hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daryn Sharp (JIRA)" <j...@apache.org>
Subject [jira] Created: (HADOOP-7180) Improve CommandFormat
Date Thu, 10 Mar 2011 22:13:59 GMT
Improve CommandFormat

                 Key: HADOOP-7180
                 URL: https://issues.apache.org/jira/browse/HADOOP-7180
             Project: Hadoop Common
          Issue Type: Improvement
            Reporter: Daryn Sharp
             Fix For: 0.22.0

CommandFormat currently takes an array and offset for parsing and returns a list of arguments.
 It'd be much more convenient to have it process a list too.  It would also be nice to differentiate
between too few and too many args instead of the generic "Illegal number of arguments".  Finally,
CommandFormat is completely devoid of tests.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message