hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From som_shekhar <kolluru.sha...@wipro.com>
Subject Isolation Runner not working as expected?
Date Tue, 29 Mar 2011 13:33:30 GMT

Hi, 
I would like to know if any one has used isolation runner for debugging?

I have tried a lot but it is not at all working?

My steps are as follows:
1. In the mapper function i have created an divided by zero exception.
2. In the hdfs-site.xml i have set the property keep.failed.task.files to
true, in all the nodes
3. Submit the job.

Now each and every task are failing because of the Arithmetic Exceptions.
Now i went to the folder local/taskTracker/jobCache/task-id/work
inside the work i can see a tmp folder which is empty.

Now as per the documentation i ran the isolation runner:
bin/hadoop org.apache.hadoop.mapred.IsolationRunner ../job.xml

But it throws me class not found exception. So i checked the class path, and
i think it is fine.

Can anyone help me?

Regards,
Sharma 
-- 
View this message in context: http://old.nabble.com/Isolation-Runner-not-working-as-expected--tp31267660p31267660.html
Sent from the Hadoop core-dev mailing list archive at Nabble.com.


Mime
View raw message