hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harsh J <qwertyman...@gmail.com>
Subject Re: How to Build Hadoop code in eclipse
Date Wed, 11 Aug 2010 16:59:48 GMT
Running the `ant eclipse-files` target will give you nearly usable
.project and .classpath files. Import the Hadoop project into Eclipse
using these.

Or you could always checkout a stable branch/tag via SVN and go ahead
with the original wiki instructions :)

On Wed, Aug 11, 2010 at 6:02 PM, Ahmad Shahzad <ashahzad4@gmail.com> wrote:
> Hi All,
>          I wanted to ask a related question to this one. How would you set
> up hadoop on eclipse if you dont want to download it from svn, rather you
> just want to configure a stable release e.g 0.20.2 on eclipse. So, i want to
> configure a stable release on eclipse and add/change the code i want and run
> it through ant.
>
> Ahmad
>
> On Sun, Aug 8, 2010 at 4:36 AM, Saikat Kanjilal <sxk1969@hotmail.com> wrote:
>
>> I've been able to build the code successfully in Eclipse by using the svn
>> plugin and importing the code and using ant.  I actually followed the wiki
>> instructions and did an svn checkout inside Eclipse and was able to run all
>> of the ant targets successfully.
>>
>> Sent from my iPhone
>>
>> On Aug 7, 2010, at 6:31 PM, thinke365 <thinke365@gmail.com> wrote:
>>
>> >
>> > Maybe the official way to build hadoop is using hudson, the developers
>> just
>> > using vim to make their work done, without IDE such as Eclipse.
>> > In my opinion, hadoop did badly to cooperate with IDE.
>> >
>> > ashish pareek wrote:
>> >>
>> >> Hello Friends,
>> >>                   If you know solution to this problem please reply
>> back.
>> >>
>> >>
>> >> On Mon, Jul 27, 2009 at 2:58 PM, ashish pareek <pareekash@gmail.com>
>> >> wrote:
>> >>
>> >>> Hi Everybody,
>> >>>
>> >>>                  Is there any easy and elaborate page where
its
>> >>> explained
>> >>> how to build hadoop code. I followed http://*wiki*.
>> apache.org/*hadoop*/*
>> >>> Eclipse*Environment instruction and even video but i getting error :
>> >>>
>> >>> BUILD FAILED : java.net.UnknownHostException : repo2.maven.org
>> >>>
>> >>> But when accessed through browser this site is working .
>> >>>
>> >>> I browse through proxy and I have set up user name ans password
>> >>> correctly.
>> >>>
>> >>> Can any one suggest the possible soultion ?
>> >>>
>> >>> Thanks in advance.
>> >>>
>> >>> Regards,
>> >>> Ashish
>> >>>
>> >>>
>> >>
>> >>
>> >
>> > --
>> > View this message in context:
>> http://old.nabble.com/How-to-Build-Hadoop-code-in-eclipse-tp24676996p29377931.html
>> > Sent from the Hadoop core-dev mailing list archive at Nabble.com.
>> >
>> >
>>
>



-- 
Harsh J
www.harshj.com

Mime
View raw message