hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From momina khan <momina.a...@gmail.com>
Subject trouble kick starting thriftfs
Date Tue, 15 Jun 2010 11:39:49 GMT

i have to use HDFS in my python project and am trying to use thriftfs for it
but i cant seem to launch the HadoopThriftServer via the
start_thrift_server.sh script

i keep getting this error
Exception in thread "main" java.lang.NoClassDefFoundError:
Caused by: java.lang.ClassNotFoundException:
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:319)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:264)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:332)
Could not find the main class:
org.apache.hadoop.thriftfs.HadoopThriftServer. Program will exit.

it says on the internet one place that path to conf must be made part of the
classpath and some place else that some jars that should be included by the
script are not part of some hadoop distros ... i have tried running the
script with hadoop-0.20.2 and hadoop-0.19.2 same error!

plz help .... am stuck at the initial phase cant move on to actual HDFS

thanks in anticipation!

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message