hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod K V (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (HADOOP-4221) TaskTracker.launchTaskForJob can be moved out of TaskTracker.localizeJob for better readability.
Date Wed, 10 Mar 2010 11:11:28 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-4221?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vinod K V resolved HADOOP-4221.
-------------------------------

    Resolution: Duplicate

MAPREDUCE-927 did this trivial refactor.

> TaskTracker.launchTaskForJob can be moved out of TaskTracker.localizeJob for better readability.
> ------------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-4221
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4221
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Vinod K V
>            Priority: Trivial
>
> The following is better readable than what is currently present.
> {code}
> private void startNewTask(tip){
>   jobFile = localizeJob(tip);
>   launchTaskForJob(tip, jobFile);
>   ...
> }
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message