hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jakob Homan (JIRA)" <j...@apache.org>
Subject [jira] Created: (HADOOP-6345) Refactor Trash::moveToTrash() and its accompanying poor tests
Date Thu, 29 Oct 2009 22:49:59 GMT
Refactor Trash::moveToTrash() and its accompanying poor tests
-------------------------------------------------------------

                 Key: HADOOP-6345
                 URL: https://issues.apache.org/jira/browse/HADOOP-6345
             Project: Hadoop Common
          Issue Type: Improvement
          Components: fs
            Reporter: Jakob Homan


We've had several issues relating to the Trash and its access via the shell, none of which
were picked up by the unit tests.  The current moveToTrash method has 8 different ways it
can terminate and sometimes uses a false value and sometimes uses an exception to indicate
failure.  This method should be refactored to improve readability and testability, and new
tests written to exercise all possible code paths.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message