hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pallavi Palleti <pallavi.pall...@corp.aol.com>
Subject Re: Using commons-net version 2.0 in maven repository for commons-net-ftp.jar
Date Wed, 12 Aug 2009 09:16:07 GMT
Hi Todd,

Yes. I am also afraid of the same. I am working on https://issues.apache.org/jira/browse/HADOOP-6187.
For now, I have kept it to use version 2.0.  

Thanks
Pallavi
----- Original Message -----
From: "Todd Lipcon" <todd@cloudera.com>
To: common-dev@hadoop.apache.org
Sent: Tuesday, August 11, 2009 11:15:54 PM GMT +05:30 Chennai, Kolkata, Mumbai, New Delhi
Subject: Re: Using commons-net version 2.0 in maven repository for  commons-net-ftp.jar

Hi Pallavi,

Which JIRA is this you're working on? I don't have any particular opinion,
but would like to watch it, as library upgrades can sometimes cause
integration issues with other packages (eg the upgrade from jetty 5 to jetty
6 caused some problems for hive)

-Todd

On Tue, Aug 11, 2009 at 12:23 AM, Pallavi Palleti <
pallavi.palleti@corp.aol.com> wrote:

> Hi all,
>
> I need to use commons-net-ftp.jar for one of the patch I am planning to
> submit. Currently, we are using version 1.4.1 from maven repository which
> doesn't have the specified jar. So, I am planning to modify ivy.xml to use
> version 2.0 which contains commons-net-ftp.jar but that would resolve other
> jars(commons-net.jar) to pull from 2.0 version. Could some one tell me if
> there is any specific reason to use 1.4.1. If so, how can I modify ivy.xml
> to use version 2.0 only for commons-net-ftp.jar. I tried searching in Google
> for the same but couldn't find useful information. It would be great if some
> one can point me to any documentation if there is any.
>
> Thanks
> Pallavi
>

Mime
View raw message