hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-6047) Code Refactoring: separate codes which implement DataTransferProtocol
Date Fri, 19 Jun 2009 00:49:07 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-6047?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tsz Wo (Nicholas), SZE updated HADOOP-6047:
-------------------------------------------

    Attachment: 6047_20090618b.patch

6047_20090618b.patch:

>   1.  It would be good to move all the code from DataXceiver.run() that reads operations
and the switch statement to DataTransferProtocol.Receiver and just call right opXXX() method
implemented by subclasses
This is a good suggestion.  I tried doing it before.  It requires some logic changes.  I would
like to keep this a copy-and-paste patch.  Let do it in a separated jira.

>   2. DataTransferProtocol.opBlockCheckSum() calls opCopyBlock() instead of opBlockCheckSum()
Good catch.

Thank you  for the comments, Suresh.

> Code Refactoring: separate codes which implement DataTransferProtocol
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-6047
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6047
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 6047_20090618.patch, 6047_20090618b.patch
>
>
> Codes implementing DataTransferProtocol are separated in DataNode, DFSClient, etc.  Also,
DataTransferProtocol only define constants but not methods.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message