hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip Zeyliger (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-398) refactor the mapred package into small pieces
Date Tue, 16 Jun 2009 05:53:07 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-398?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12719937#action_12719937
] 

Philip Zeyliger commented on HADOOP-398:
----------------------------------------

+1

Perhaps move the DistributedCache while you're at it?

> refactor the mapred package into small pieces
> ---------------------------------------------
>
>                 Key: HADOOP-398
>                 URL: https://issues.apache.org/jira/browse/HADOOP-398
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.4.0
>            Reporter: Owen O'Malley
>            Assignee: Owen O'Malley
>
> The mapred package has gotten too big, so I propose changing it to split it into parts.
> I propose the following splits:
> org.apache.hadoop.mapred = client API
> org.apache.hadoop.mapred.task = code for task tracker
> org.apache.hadoop.mapred.job = code for job tracker
> org.apache.hadoop.mapred.utils = non public code that is shared between the servers
> Does anyone have any other divisions that would help?
> I would make the classes sent through RPC public classes in the server's package.
> Thoughts?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message