hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-6047) Code Refactoring: separate codes which implement DataTransferProtocol
Date Fri, 19 Jun 2009 00:15:07 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-6047?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12721575#action_12721575

Suresh Srinivas commented on HADOOP-6047:

# It would be good to move all the code from DataXceiver.run() that reads operations and the
switch statement to DataTransferProtocol.Receiver and just call right opXXX() method implemented
by subclasses
# DataTransferProtocol.opBlockCheckSum() calls opCopyBlock() instead of opBlockCheckSum()

> Code Refactoring: separate codes which implement DataTransferProtocol
> ---------------------------------------------------------------------
>                 Key: HADOOP-6047
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6047
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 6047_20090618.patch
> Codes implementing DataTransferProtocol are separated in DataNode, DFSClient, etc.  Also,
DataTransferProtocol only define constants but not methods.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message