hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5974) Add orthogonal fault injection mechanism/framework
Date Mon, 08 Jun 2009 20:11:07 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5974?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12717385#action_12717385
] 

Tsz Wo (Nicholas), SZE commented on HADOOP-5974:
------------------------------------------------

>% ant run-test-hdfs -DallFaultProbability=0 -DBlockReceiverFaultProbability=10

The naming convention may be better to have something like fault.probability.*, fault.probability.datanode.BlockReceiver,
etc.

> Add orthogonal fault injection mechanism/framework
> --------------------------------------------------
>
>                 Key: HADOOP-5974
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5974
>             Project: Hadoop Core
>          Issue Type: Test
>          Components: test
>            Reporter: Konstantin Boudnik
>            Assignee: Konstantin Boudnik
>
> It'd be great to have a fault injection mechanism for Hadoop.
> Having such solution in place will allow to increase test coverage of error handling
and recovery mechanisms, reduce reproduction time and increase the reproduction rate of the
problems.
> Ideally, the system has to be orthogonal to the current code and test base. E.g. faults
have to be injected at build time and would have to be configurable, e.g. all faults could
be turned off, or only some of them would be allowed to happen. Also, fault injection has
to be separated from production build. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message