hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5619) Convert FSImage.removedStorageDirs into a map.
Date Fri, 01 May 2009 20:49:30 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5619?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12705111#action_12705111
] 

Konstantin Shvachko commented on HADOOP-5619:
---------------------------------------------

# {{removedStorageDirs}} should be declared as an interface {{Map<>}} rather than a
class {{TreeMap<>}}.
# Same with {{getRemovedStorageDirs()}} - it should return an interface.
# Could you please verify whether can avoid initializing it in declaration section. It would
be better not to.
# Please fix warnings in the import section. Also I don't think changing of the order of includes
is necessary.
# What about test failures?

> Convert FSImage.removedStorageDirs into a map.
> ----------------------------------------------
>
>                 Key: HADOOP-5619
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5619
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>    Affects Versions: 0.21.0
>            Reporter: Konstantin Shvachko
>            Assignee: Boris Shkolnik
>             Fix For: 0.21.0
>
>         Attachments: HADOOP-5619.patch
>
>
> {{FSImage.removedStorageDirs}} is declared as an {{ArrayList}}. In order to avoid adding
the same directory twice into {{removedStorageDirs}} we should convert it into a map.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message