hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5406) Misnamed function in ZlibCompressor.c
Date Tue, 05 May 2009 19:08:31 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5406?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12706159#action_12706159
] 

Hudson commented on HADOOP-5406:
--------------------------------

Integrated in Hadoop-trunk #827 (See [http://hudson.zones.apache.org/hudson/job/Hadoop-trunk/827/])
    . Fix JNI binding for ZlibCompressor::setDictionary. Contributed by Lars Francke.


> Misnamed function in ZlibCompressor.c
> -------------------------------------
>
>                 Key: HADOOP-5406
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5406
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: native
>    Affects Versions: 0.19.1
>            Reporter: Lars Francke
>            Assignee: Lars Francke
>            Priority: Minor
>             Fix For: 0.21.0
>
>         Attachments: HADOOP-5406.patch
>
>
> All methods in ZlibCompressor.c are named like "Java_org_apache_hadoop_io_compress_zlib_ZlibCompressor_METHODNAME"
> There is one that is called: Java_org_apache_hadoop_io_compress_ZlibCompressor_setDictionary

> Should be: Java_org_apache_hadoop_io_compress_zlib_ZlibCompressor_setDictionary

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message