hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Boudnik (JIRA)" <j...@apache.org>
Subject [jira] Deleted: (HADOOP-5868) FSDirectory.renameTo(String, String) has unclear logic around unprotectedRenameTo() call
Date Wed, 20 May 2009 21:22:45 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-5868?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Konstantin Boudnik deleted HADOOP-5868:
---------------------------------------


> FSDirectory.renameTo(String, String) has unclear logic around unprotectedRenameTo() call
> ----------------------------------------------------------------------------------------
>
>                 Key: HADOOP-5868
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5868
>             Project: Hadoop Core
>          Issue Type: Improvement
>            Reporter: Konstantin Boudnik
>            Assignee: Konstantin Boudnik
>            Priority: Minor
>
> Current implementation of renameTo(String, String) has this piece of the code at the
end:
> ...
>     if (!unprotectedRenameTo(src, dst, now))
>       return false;
>     fsImage.getEditLog().logRename(src, dst, now);
>     return true;
> }
> The logic of the code isn't very clear from a very sight. A slight modification is recommended
to make it more readable.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message