hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Douglas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5738) Split waiting tasks field in JobTracker metrics to individual tasks
Date Mon, 04 May 2009 06:49:30 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5738?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12705502#action_12705502

Chris Douglas commented on HADOOP-5738:

+1 on the changes, though the new JobInstrumentation method should be named addWaitingMap*s*
for symmetry with the other methods

bq. Also, to ensure backward compatibility later, maybe we should port this patch to 0.20

Per the taxonomy in HADOOP-5073, the instrumentation metrics are called out as a public-stable
API, and are supposed to remain unchanged except in major versions (for this patch pre-1.0,
this means 0.21). If this could be applied to 0.20 at all, Sreekanth's original fix retaining
the waiting_tasks metric would be the correct one by that reasoning.

Since it applies cleanly to 0.20, I'd lean towards putting it in 0.21 and let interested parties
apply it themselves.

> Split waiting tasks field in JobTracker metrics to individual tasks
> -------------------------------------------------------------------
>                 Key: HADOOP-5738
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5738
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: mapred, metrics
>            Reporter: Sreekanth Ramakrishnan
>            Assignee: Sreekanth Ramakrishnan
>         Attachments: HADOOP-5738-1.patch, HADOOP-5738-2.patch
> Currently, job tracker metrics reports waiting tasks as a single field in metrics. It
would be better if we can split waiting tasks into maps and reduces. 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message