hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luca Telloli (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-5721) Provide EditLogFileInputStream and EditLogFileOutputStream as independent classes
Date Mon, 11 May 2009 14:23:46 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-5721?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Luca Telloli updated HADOOP-5721:
---------------------------------

    Attachment: HADOOP-5721.patch

Addressed Konstantin's requests: 

- The patch uses the new test structure 
- I didn't find any reference to sizeOutputFlushBuffer in EditLogFileOutputStream 
- The override lines have been corrected

Additionally, I removed an unused import from the previous patch in EditLogFileOutputStream.


namenode tests pass without errors on my machine 

> Provide EditLogFileInputStream and EditLogFileOutputStream as independent classes 
> ----------------------------------------------------------------------------------
>
>                 Key: HADOOP-5721
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5721
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>    Affects Versions: 0.19.1
>            Reporter: Luca Telloli
>            Priority: Minor
>             Fix For: 0.21.0
>
>         Attachments: HADOOP-5721.patch, HADOOP-5721.patch, HADOOP-5721.patch, HADOOP-5721.patch,
HADOOP-5721.patch, HADOOP-5721.patch, HADOOP-5721.patch, HADOOP-5721.patch, HADOOP-5721.patch,
HADOOP-5721.patch
>
>
> EditLogFileInputStream and EditLogFileOutputStream are currently part of FSEditLog. With
this patch we want to extract them and provide as independent classes. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message