hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5840) Move new per-daemon Thrift contrib into a new contrib project/package layout
Date Thu, 14 May 2009 20:31:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5840?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12709567#action_12709567
] 

Todd Lipcon commented on HADOOP-5840:
-------------------------------------

Copying over relevant comments from the original discussion:

Todd said:
{quote}
I'd also like to propose moving this code into contrib/thrift rather than contrib/thriftfs.
The motivation for this is that I will soon be working on JobTracker and TaskTracker thrift
plugins, and there's a lot of common code I want to share. Putting that code in a module called
"thriftfs" seems incorrect. Additionally, contrib/thriftfs currently is the home for two entirely
separate projects - this, and the earlier "proxy style" thrift wrapper of the DFS client.
Since these two projects share no code, it makes no sense for them to be in the same contrib
dir.

If no one has any objections, I'll do this move in the next day or two.
{quote}

Dhruba said:
{quote}
> "proxy style" thrift wrapper of the DFS client.

This code should be made obselete (and deleted) when this patch goes into trunk. It would
be nice to keep the name of the file system related classes (from this patch)to be org.apache.hadoop.thriftfs
though.
{quote}

Todd said:
{quote}
bq.  It would be nice to keep the name of the file system related classes (from this patch)to
be org.apache.hadoop.thriftfs though.

Sure thing. You're fine with renaming the directory to src/contrib/thrift though?
{quote}

Dhruba:
{quote}
Sure.

The only caveat is that the convention is to match the package name with the directory name.
So, if you have the package name is org.apache.hadoop.thriftfs, then it might be convenient
to keep the directory name same as what we got now.
{quote}

Todd:
{quote}
How about a package structure like:

    * org.apache.hadoop.thrift - base service, utility classes
    * org.apache.hadoop.thrift.hdfs - NameNodePlugin, DataNodePlugin, common DFS-related "convert
to thrift" functions
    * org.apache.hadoop.thrift.mapred - for JobTracker/TaskTracker thrift interfaces when
they come along

I think this makes the most sense to me at this point. Renaming contrib/thriftfs to contrib/thrift
is a pain, but I would hate to see a mapred dir inside a "thriftfs" package or contrib project.
{quote}

Dhruba:
{quote}
How about a package structure that is like this:

org.apache.hadoop.thriftfs
org.apache.hadoop.thriftmp
{quote}

Todd:
{quote}
Where does the common code go? In the most recent patch, the NN and DN services extend a common
HadoopService which exposes common elements like JVM stats, VersionInfo, and Metrics. I'd
certainly want to share this code between mr and fs. There's also some common code for starting
up a Thrift server, handling UserGroupInformation, etc.
{quote}

> Move new per-daemon Thrift contrib into a new contrib project/package layout
> ----------------------------------------------------------------------------
>
>                 Key: HADOOP-5840
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5840
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: contrib/thiftfs
>            Reporter: Todd Lipcon
>
> The discussion in HADOOP-4707 has moved away from the original intent of that issue.
Opening this one to continue the discussion of this rename/move.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message