hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-5015) Separate block/replica management code from FSNamesystem
Date Mon, 04 May 2009 19:14:30 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-5015?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Suresh Srinivas updated HADOOP-5015:

    Attachment: blkmanager.patch

Incorporated all the comments in the attached patch, except the following:
# Not moving {{generationStamp}} to blockManager as it is used in {{FSNamesystem}} and updated
during file creation
# {{blockInvalidateLimit}} can be renamed in a separate change
# {{replicationRecheckInterval}} should be moved into {{ReplicationMonitor}} in a separate

> Separate block/replica management code from FSNamesystem
> --------------------------------------------------------
>                 Key: HADOOP-5015
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5015
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Hairong Kuang
>            Assignee: Suresh Srinivas
>             Fix For: 0.21.0
>         Attachments: blkmanager.patch, blkmanager.patch
> Currently FSNamesystem contains a big amount of code that manages blocks and replicas.
The code scatters in FSNamesystem and it is hard to read and maintain. It would be nice to
move the code to a separate class called, for example, BlockManager. 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message