hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5818) Revert the renaming from checkSuperuserPrivilege to checkAccess by HADOOP-5643
Date Thu, 14 May 2009 20:21:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5818?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12709562#action_12709562
] 

Tsz Wo (Nicholas), SZE commented on HADOOP-5818:
------------------------------------------------

{noformat}
     [exec] -1 overall.
     [exec]
     [exec]     +1 @author.  The patch does not contain any @author tags.
     [exec]
     [exec]     -1 tests included.  The patch doesn't appear to include any new or modified
tests.
     [exec]                         Please justify why no tests are needed for this patch.
     [exec]
     [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
     [exec]
     [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler
warnings.
     [exec]
     [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
     [exec]
     [exec]     +1 Eclipse classpath. The patch retains Eclipse classpath integrity.
     [exec]
     [exec]     +1 release audit.  The applied patch does not increase the total number of
release audit warnings.
{noformat}
Since this patch is reverting a renaming of a private method, I will commit it without submitting
to Hudson.

> Revert the renaming from checkSuperuserPrivilege to checkAccess by HADOOP-5643
> ------------------------------------------------------------------------------
>
>                 Key: HADOOP-5818
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5818
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Amar Kamat
>         Attachments: HADOOP-5818-v1.0.patch
>
>
> HADOOP-5643 renamed FSNamesystem.checkSuperuserPrivilege to checkAccess.  However, "checkAccess"
is confusing in FSNamesystem since there are other methods, checkPathAccess(..), checkParentAccess(..)
and checkAncestorAccess(..) which have different meanings.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message