hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sharad Agarwal (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5717) Create public enum class for the Framework counters in org.apache.hadoop.mapreduce
Date Thu, 30 Apr 2009 07:47:30 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5717?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12704517#action_12704517
] 

Sharad Agarwal commented on HADOOP-5717:
----------------------------------------

The resource bundle files - (Task_Counter.properties and JobInProgress_Counter.properties)
should be renamed as per the new class names and moved to mapreduce package.

> Create public enum class for the Framework counters in org.apache.hadoop.mapreduce
> ----------------------------------------------------------------------------------
>
>                 Key: HADOOP-5717
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5717
>             Project: Hadoop Core
>          Issue Type: Improvement
>            Reporter: Owen O'Malley
>            Assignee: Amareshwari Sriramadasu
>             Fix For: 0.21.0
>
>         Attachments: patch-5717-1.txt, patch-5717.txt
>
>
> We need to make the counters from the framework visible, but they should be in the new
package (org.apache.hadoop.mapreduce).
> For compatibility, we need the old class of counters to recognize the old class and package
names and convert them over to the new names. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message