hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip Zeyliger (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5658) Eclipse templates fail out of the box; need updating
Date Sat, 18 Apr 2009 00:12:14 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12700387#action_12700387
] 

Philip Zeyliger commented on HADOOP-5658:
-----------------------------------------

Eclipse on OS X is definitely whinier than on Linux, but I've gotten this to work on both.
 I'm running through it as I type this up:

# Turn off Build Automatically
# Make sure that Eclipse Preferences...Installed JREs contains "JVM 1.6" 
# Make sure ANT_HOME is set in Classpath Variables in Eclipse settings.
# Checked out Hadoop using Subversive as a New Java Project; using Java 1.6; output path is
build/eclipse-classfiles
# {{patch -p0 < /tmp/HADOOP-5658-v3.patch}}
# {{ant eclipse-files}} (When doing this for myself, I typically do compile-core-test at this
point too, just to accelerate things later.)
# Right-click on project and hit refresh in Eclipse
# Right-click on project and hit Build Project in Eclipse
# Refresh again
# Build project again.
# Check Problems: no errors, just warnings.  Good.

So, it worked pretty much for me.  I haven't managed to avoid the refresh/build twice problem,
though I've gotten it to work better if I built compile-core-test on the command line ahead
of time.

What version of Eclipse are you running?  I'm at 3.4.2 (M20090211-1700) (on OS X).  To figure
out what's going on, we'll also have to compare our .classpath, .externalToolBuilders/Hadoop_Ant_Builder.launch,
and .project files.  I'm attaching mine as eclipse.zip, for comparison.  Can you send a screenshot
of the error you're seeing?

> Eclipse templates fail out of the box; need updating
> ----------------------------------------------------
>
>                 Key: HADOOP-5658
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5658
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: build
>         Environment: Eclipse Ganymede, both on Linux and OS X.
>            Reporter: Philip Zeyliger
>         Attachments: disable java builder.pdf, eclipse-problems.txt, HADOOP-5658-v2.patch,
HADOOP-5658-v3.patch, HADOOP-5658.patch
>
>
> The Hadoop templates, when run "out of the box" have Eclipse build "problems".  I've
produced a small patch that fixes it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message