hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5467) Create an offline fsimage image viewer
Date Sat, 18 Apr 2009 01:23:14 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5467?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12700405#action_12700405

Tsz Wo (Nicholas), SZE commented on HADOOP-5467:

Patch mostly look good. Some comments:

- Naming is not consistent: Some classes are called FSImageXxx (e.g. FSImageVisitor, IndentedFSImageVisitor)
and some are called ImageXxx (e.g. LsImageVisitor, OfflineImageViewer.) I prefer names without
FS since the context is clear. Anyway, make them consistent.

- Naming again: Names like XMLFSImageVisitor are hard to be parsed. XmlFsImageVisitor is better.
See also [Doug's comment|http://issues.apache.org/jira/browse/HADOOP-4044?focusedCommentId=12637296#action_12637296].

Other suggestions (may be considered as future extensions):

- I like that the patch using a visitor pattern to implement image loading. It would be great
if oiv and FSImage could use the same codes to load image. It is good to combine these two
image loading implementations.

- Why values are strings (e.g. visit(FSImageElement element, String value))? Current approach
is to convert everything including date, int, etc. to String. It works fine for oiv since
it deals with text output. But it won't be good for binary image visitor.

> Create an offline fsimage image viewer
> --------------------------------------
>                 Key: HADOOP-5467
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5467
>             Project: Hadoop Core
>          Issue Type: New Feature
>          Components: dfs
>            Reporter: Jakob Homan
>            Assignee: Jakob Homan
>         Attachments: fsimage.xml, fsimageV18, fsimageV19, HADOOP-5467.patch, HADOOP-5467.patch,
HADOOP-5467.patch, HADOOP-5467.patch, HADOOP-5467.patch
> It would be useful to have a tool to examine/dump the contents of the fsimage file to
human-readable form.  This would allow analysis of the namespace (file usage, block sizes,
etc) without impacting the operation of the namenode.  XML would be reasonable output format,
as it can be easily viewed, compressed and manipulated via either XSLT or XQuery.  
> I've started work on this and will have an initial version soon.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message