hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5406) Misnamed function in ZlibCompressor.c
Date Mon, 09 Mar 2009 02:05:56 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5406?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12680034#action_12680034

Hadoop QA commented on HADOOP-5406:

-1 overall.  Here are the results of testing the latest attachment 
  against trunk revision 751463.

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no tests are needed for this patch.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs warnings.

    +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

    +1 release audit.  The applied patch does not increase the total number of release audit

    -1 core tests.  The patch failed core unit tests.

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-minerva.apache.org/30/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-minerva.apache.org/30/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-minerva.apache.org/30/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-minerva.apache.org/30/console

This message is automatically generated.

> Misnamed function in ZlibCompressor.c
> -------------------------------------
>                 Key: HADOOP-5406
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5406
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: native
>    Affects Versions: 0.19.1
>            Reporter: Lars Francke
>            Priority: Minor
>         Attachments: HADOOP-5406.patch
> All methods in ZlibCompressor.c are named like "Java_org_apache_hadoop_io_compress_zlib_ZlibCompressor_METHODNAME"
> There is one that is called: Java_org_apache_hadoop_io_compress_ZlibCompressor_setDictionary

> Should be: Java_org_apache_hadoop_io_compress_zlib_ZlibCompressor_setDictionary

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message