hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Douglas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5363) Proxying for multiple HDFS clusters of different versions
Date Tue, 24 Mar 2009 07:07:51 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5363?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12688593#action_12688593
] 

Chris Douglas commented on HADOOP-5363:
---------------------------------------

This looks good. Just a few small notes:

* Since pickOneAddress was added in support of hdfsproxy (HADOOP-4575), if it's no longer
needed then it should be removed from HftpFileSystem
* Instead of pulling the configuration out of the context in doGet, it can be saved in HttpServlet::init
in ProxyForwardServlet.
* Unless {{doForward}} has special meaning, it should probably not be confused with {{doGet}},
{{doHead}}, etc. that are part of HttpServlet. Either putting the body of that method in {{doGet}}
or renaming it would make it more readable. {{doGet}} should have an @Override annotation
* Please include javadoc for public methods, where reasonable.
* I'm confused by {{getServletPath}} on the servlets; isn't this usually on the HttpServletRequest,
set by the server to the matching part of the URI? Unless it has special meaning: rather than
overloading {{getServletPath}} to return a fixed String, then changing behavior of {{doForward}}
based on whether it matches "/path", it might make more sense to put the logic in the "else"
block in a method, then override it in the ProxyFileForward servlet.
* ProxyUtil::main should print usage when it has too few arguments rather than throwing an
exception for {{-get}}.

> Proxying for multiple HDFS clusters of different versions
> ---------------------------------------------------------
>
>                 Key: HADOOP-5363
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5363
>             Project: Hadoop Core
>          Issue Type: New Feature
>          Components: contrib/hdfsproxy
>            Reporter: Kan Zhang
>            Assignee: zhiyong zhang
>         Attachments: HADOOP-5363.patch
>
>
> A single hdfsproxy server should be able to proxy for multiple HDFS clusters, whose Hadoop
versions may be different from each other.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message