hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Francke (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5406) Misnamed function in ZlibCompressor.c
Date Mon, 09 Mar 2009 12:14:50 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5406?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12680133#action_12680133
] 

Lars Francke commented on HADOOP-5406:
--------------------------------------

No tests included as there is nothing to test really. I just renamed a function to comply
to JNI standards but this function is not used anywhere in the Hadoop-Codebase (as far as
I can tell).

I have no idea how my patch causes the jobHistoryLocation test to fail. I guess I'll have
to investigate.

> Misnamed function in ZlibCompressor.c
> -------------------------------------
>
>                 Key: HADOOP-5406
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5406
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: native
>    Affects Versions: 0.19.1
>            Reporter: Lars Francke
>            Priority: Minor
>         Attachments: HADOOP-5406.patch
>
>
> All methods in ZlibCompressor.c are named like "Java_org_apache_hadoop_io_compress_zlib_ZlibCompressor_METHODNAME"
> There is one that is called: Java_org_apache_hadoop_io_compress_ZlibCompressor_setDictionary

> Should be: Java_org_apache_hadoop_io_compress_zlib_ZlibCompressor_setDictionary

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message