hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4655) FileSystem.CACHE should be ref-counted
Date Mon, 09 Mar 2009 17:57:50 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4655?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12680216#action_12680216
] 

Doug Cutting commented on HADOOP-4655:
--------------------------------------

> Changed name of new API to FileSystem.createNewInstance().

A nit: that seems redundant.  I'd rather see this as just 'create()' or 'newInstance()', but
not both.


> FileSystem.CACHE should be ref-counted
> --------------------------------------
>
>                 Key: HADOOP-4655
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4655
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs, fs
>    Affects Versions: 0.18.1, 0.18.2, 0.19.0, 0.19.1, 0.20.0
>            Reporter: Hong Tang
>            Assignee: dhruba borthakur
>             Fix For: 0.20.0
>
>         Attachments: FileSystemUnique.patch, FileSystemUnique.txt
>
>
> FileSystem.CACHE is not ref-counted, and could lead to resource leakage.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message