hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jakob Homan (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-4942) Remove getName() and getNamed(String name, Configuration conf)
Date Tue, 03 Feb 2009 18:31:59 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-4942?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jakob Homan updated HADOOP-4942:
--------------------------------

    Attachment: HADOOP-4942.patch

Patch removes all references to the two methods, removes overridden implementations and tweaks
the tests that refer to them.  A lot of tests expect a string rather than a URI and it may
or may not be worth it to re-jigger them to use the URI directly.
Unit tests pass except for known-bad HADOOP-4907.
{noformat}
     [exec] +1 overall.  
     [exec] 
     [exec]     +1 @author.  The patch does not contain any @author tags.
     [exec] 
     [exec]     +1 tests included.  The patch appears to include 33 new or modified tests.
     [exec] 
     [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
     [exec] 
     [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler
warnings.
     [exec] 
     [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
     [exec] 
     [exec]     +1 Eclipse classpath. The patch retains Eclipse classpath integrity.
     [exec] 
     [exec]     +1 release audit.  The applied patch does not increase the total number of
release audit warnings.
{noformat}

> Remove getName() and getNamed(String name, Configuration conf)
> --------------------------------------------------------------
>
>                 Key: HADOOP-4942
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4942
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: fs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Jakob Homan
>         Attachments: HADOOP-4942.patch
>
>
> Remove these two methods:
> - public String getName()
> - public static FileSystem getNamed(String name, Configuration conf)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message