hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "dhruba borthakur (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4655) FileSystem.CACHE should be ref-counted
Date Fri, 27 Feb 2009 22:49:12 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4655?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12677578#action_12677578
] 

dhruba borthakur commented on HADOOP-4655:
------------------------------------------

I would rather not deprecate the method that uses the CACHE because that behaviour might be
optimal for some class of applications, do you agree?

I will take Hong's suggestion and change the name of this new API  to FileSystem.newInstance().

> FileSystem.CACHE should be ref-counted
> --------------------------------------
>
>                 Key: HADOOP-4655
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4655
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs, fs
>    Affects Versions: 0.18.1, 0.18.2, 0.19.0, 0.19.1, 0.20.0
>            Reporter: Hong Tang
>            Assignee: dhruba borthakur
>         Attachments: FileSystemUnique.patch
>
>
> FileSystem.CACHE is not ref-counted, and could lead to resource leakage.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message