hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vivek Ratan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-5199) A proposal to merge common functionality of various Schedulers
Date Tue, 10 Feb 2009 04:50:59 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-5199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12672153#action_12672153

Vivek Ratan commented on HADOOP-5199:

If there is an apprehension of adding the {{HadoopScheduler}} class into the framework, we
can also consider replacing TaskScheduler's assignTasks() with HadooPScheduler's assignTasks()
and getting rid of {{HadoopScheduler}}. This wudl mean moving the common code to {{TaskScheduler}},
but still allowing a subclass of {{TaskScheduler}} to overwrite assignTasks() with their own

> A proposal to merge common functionality of various Schedulers
> --------------------------------------------------------------
>                 Key: HADOOP-5199
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5199
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: mapred
>            Reporter: Vivek Ratan
>         Attachments: 5199.1.patch
> There are at least 3 Schedulers in Hadoop today: Default, Capacity, and Fairshare. Over
time, we're seeing a lot of functionality common to all three. Many bug fixes, improvements
to existing functionality, and new functionality are applicable to all three schedulers. This
trend seems to be getting stronger, as we notice similar problems, solutions, and ideas. This
is a proposal to detect and consolidate such common functionality, while at the same time,
allowing for differences in behavior and leaving the door open for other schedulers to be
built, as per HADOOP-3412. 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message