hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4795) Lease monitor may get into an infinite loop
Date Mon, 08 Dec 2008 22:29:44 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4795?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12654608#action_12654608

Konstantin Shvachko commented on HADOOP-4795:

# I would rename Monitor.check() to something like checkLeases().
# {{esle}} statement can be removed.
# Wrapping String Collection into {{ArrayList}} can be replaced by collecting paths to be
removed in an {{ArrayList}} and then removing them afterwards in a separate loop. This will
be much less copying.

> Lease monitor may get into an infinite loop
> -------------------------------------------
>                 Key: HADOOP-4795
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4795
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Priority: Blocker
>             Fix For: 0.18.3
>         Attachments: 4795_20081205.patch, 4795_20081208.patch
> If a lease is not found in the namespace for some reasons (e.g. bugs), lease monitor
may get into an infinite loop.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message