hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4226) LineReader::readLine cleanup
Date Wed, 01 Oct 2008 13:29:48 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4226?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12636022#action_12636022
] 

Hudson commented on HADOOP-4226:
--------------------------------

Integrated in Hadoop-trunk #620 (See [http://hudson.zones.apache.org/hudson/job/Hadoop-trunk/620/])
    . Refactor and document LineReader to make it more readily
understandable. Contributed by Yuri Pradkin.


> LineReader::readLine cleanup
> ----------------------------
>
>                 Key: HADOOP-4226
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4226
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.19.0
>            Reporter: Yuri Pradkin
>            Assignee: Yuri Pradkin
>            Priority: Minor
>             Fix For: 0.20.0
>
>         Attachments: HADOOP-4226.patch, HADOOP-4226.patch
>
>
> I've been looking at HADOOP-4010 and realized that readLine is pretty convoluted.  I
changed the implementation which made it hopefully a little easier to read/validate/understand.
 
> I've had some problems testing it locally, so I'll submit it for Hudson to test.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message