hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amareshwari Sriramadasu (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4122) Duplicate code in JobHistory TaskAttempt's can be collapsed into super class.
Date Fri, 03 Oct 2008 08:46:44 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4122?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12636575#action_12636575
] 

Amareshwari Sriramadasu commented on HADOOP-4122:
-------------------------------------------------

The methods logFailed() and logKilled() in JobInfo can also be merged into one method, since
they differ only in one value. 

All the classes and all the methods to log the Job and task information, in JobHistory, are
exposed to public, which is not necessary. They should be package private. This jira can make
them package private. 

Thoughts?


> Duplicate code in JobHistory TaskAttempt's can be collapsed into super class. 
> ------------------------------------------------------------------------------
>
>                 Key: HADOOP-4122
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4122
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: mapred
>            Reporter: Amareshwari Sriramadasu
>            Assignee: Amareshwari Sriramadasu
>            Priority: Blocker
>             Fix For: 0.19.0
>
>
> There is a lot of common code for MapAttempt, ReduceAttempt. All the duplicate code can
be moved to TaskAttempt class. The methods logFailed() and logKilled() methods differ only
in one string. They can be collapased into a single method.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message