hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dipanjan Das (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4429) Misconfigured UNIX Groups Break Hadoop
Date Thu, 16 Oct 2008 17:35:44 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4429?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12640234#action_12640234

Dipanjan Das commented on HADOOP-4429:

I have been trying to install hadoop on my linux machine to create a development environment,
and I have been following instructions on this page:


However, I could not proceed with the installation because of a group ID that my system associates
with my user name, breaks hadoop. As an example, if I run:

$ bin/hadoop dfs -ls 

I get the following error:

08/10/16 13:10:13 WARN fs.FileSystem: uri=hdfs://localhost:54310
javax.security.auth.login.LoginException: Login failed: id: cannot find name for group ID

       at org.apache.hadoop.security.UnixUserGroupInformation.login(UnixUserGroupInformation.java:250)
       at org.apache.hadoop.security.UnixUserGroupInformation.login(UnixUserGroupInformation.java:275)
       at org.apache.hadoop.security.UnixUserGroupInformation.login(UnixUserGroupInformation.java:257)
       at org.apache.hadoop.security.UserGroupInformation.login(UserGroupInformation.java:67)
       at org.apache.hadoop.fs.FileSystem$Cache$Key.<init>(FileSystem.java:1353)
       at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:1289)
       at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:203)
       at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:108)
       at org.apache.hadoop.fs.FsShell.init(FsShell.java:87)
       at org.apache.hadoop.fs.FsShell.run(FsShell.java:1717)
       at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
       at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:79)
       at org.apache.hadoop.fs.FsShell.main(FsShell.java:1866)
Bad connection to FS. command aborted. 

Here, "1106734464" is a group ID that my username belongs to. When I type 

$ groups

I get

hadoop id: cannot find name for group ID 1106734464

Here, "hadoop" is a username that I created for running hadoop. Similarly, if I run:

$ id

I get:

uid=501(hadoop) gid=501(hadoop) groups=501(hadoop),1106734464

Is this a bug in hadoop?

> Misconfigured UNIX Groups Break Hadoop
> --------------------------------------
>                 Key: HADOOP-4429
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4429
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs
>         Environment: UNIX, Linux
>            Reporter: Alex Loddengaard
>            Priority: Minor
> If a UNIX user has misconfigured groups, either locally or through LDAP, then Hadoop
will not be able to start.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message