hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4226) LineReader::readLine cleanup
Date Mon, 22 Sep 2008 17:30:44 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4226?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12633389#action_12633389
] 

Hadoop QA commented on HADOOP-4226:
-----------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12390601/HADOOP-4226.patch
  against trunk revision 697306.

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no tests are needed for this patch.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs warnings.

    -1 core tests.  The patch failed core unit tests.

    -1 contrib tests.  The patch failed contrib unit tests.

Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3344/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3344/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3344/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3344/console

This message is automatically generated.

> LineReader::readLine cleanup
> ----------------------------
>
>                 Key: HADOOP-4226
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4226
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.19.0
>            Reporter: Yuri Pradkin
>            Assignee: Yuri Pradkin
>            Priority: Minor
>         Attachments: HADOOP-4226.patch
>
>
> I've been looking at HADOOP-4010 and realized that readLine is pretty convoluted.  I
changed the implementation which made it hopefully a little easier to read/validate/understand.
 
> I've had some problems testing it locally, so I'll submit it for Hudson to test.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message