hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hong Tang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3315) New binary file format
Date Wed, 10 Sep 2008 18:53:44 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3315?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12629910#action_12629910
] 

Hong Tang commented on HADOOP-3315:
-----------------------------------

> If you instead extended ByteArrayOutputStream, BoundedByteArrayOutputStream would only
need to override the two write() methods, rather than implement all of the methods.
[Hong] This class is optimized for TFile key appending, The whole implementation only consists
of the two writes() and needs nothing else from BufferedInputStream.

> Then it should be named something different. Why support negative values at all if you
don't use them? Lucene also defines a VInt format that might be considered. Personally, I'd
prefer Hadoop used a single VInt format and I don't think it is worth defining yet another
VInt and String format for TFile is wise.
[Hong] We can sure rename it to avoid confusion. We do need to represent negative integers.
But they are either very small (such as -1, or -2), or very large (-1M).

> Then CompressionCodecFactory should be extended, rather than duplicated.
[Hong] This is a first cut implementation. As it stand, it does not duplicate much code. We
will consider refactoring based on your suggestions later.

> New binary file format
> ----------------------
>
>                 Key: HADOOP-3315
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3315
>             Project: Hadoop Core
>          Issue Type: New Feature
>          Components: io
>            Reporter: Owen O'Malley
>            Assignee: Amir Youssefi
>         Attachments: HADOOP-3315_TFILE_PREVIEW.patch, HADOOP-3315_TFILE_PREVIEW_WITH_LZO_TESTS.patch,
TFile Specification Final.pdf
>
>
> SequenceFile's block compression format is too complex and requires 4 codecs to compress
or decompress. It would be good to have a file format that only needs 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message