hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashish Thusoo (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4070) [Hive] Provide a mechanism for registering UDFs from the query language
Date Thu, 18 Sep 2008 01:45:46 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4070?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12632050#action_12632050

Ashish Thusoo commented on HADOOP-4070:


Looks good. Thanks for the contribution.

Only comment that I have is that in the patch you have duplicated the code for compile-test
in ql/build.xml

Would be better if instead we introduced a new target for building the udf jar (on similar
lines as gen-test) and have a dummy gen-test-jar in build-common.xml which gets overwritten
in ql/build.xml...

Its upto you if you want to incorporate that... But this is good as is...

Thanks again for the contribution... keep them rolling :)

> [Hive] Provide a mechanism for registering UDFs from the query language
> -----------------------------------------------------------------------
>                 Key: HADOOP-4070
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4070
>             Project: Hadoop Core
>          Issue Type: New Feature
>          Components: contrib/hive
>            Reporter: Tom White
>            Assignee: Tom White
>         Attachments: hadoop-4070-v2.patch, hadoop-4070.patch
> UDFs (user defined functions) in Hive are currently actually built-in functions. This
issue is to develop a packaging and registration mechanism so users can add their own functions
at runtime.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message