hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3903) Rename dfs package to hdfs for the generated servlet classes
Date Fri, 08 Aug 2008 20:31:44 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3903?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12621044#action_12621044

Tsz Wo (Nicholas), SZE commented on HADOOP-3903:

The old packages names for namenode and datanode webapps are "org.apache.hadoop.dfs".  I changed
them to "org.apache.hadoop.hdfs" in my previous patch.

Is it better to change them to "org.apache.hadoop.hdfs.server.namenode.servlet" and "org.apache.hadoop.hdfs.server.datanode.servlet",

Also, the directory "${src.webapps}/dfs" is indeed for the namenode only.  Is it better to
rename it to "namenode", other than "hdfs"?

> Rename dfs package to hdfs for the generated servlet classes
> ------------------------------------------------------------
>                 Key: HADOOP-3903
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3903
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 3903_20080805.patch, 3903_20080806.patch, 3903_20080806b.patch,
> The package name for the generated servlet classes is still org.apache.hadoop.dfs.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message