hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemanth Yamijala (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3479) Implement configuration items useful for Hadoop resource manager (v1)
Date Tue, 01 Jul 2008 23:52:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3479?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12609748#action_12609748
] 

Hemanth Yamijala commented on HADOOP-3479:
------------------------------------------

bq. I can't see where the 'overlay' feature is ever used. Should we eliminate it?

I thought this was being used to note which are the values that are stored through 'set' operations,
because the set API adds the values to the overlay and then to the properties instance. But
I realize now there is no way to retrieve these, because getOverlay is a private method. So,
I can remove this. Just to be safe though, should I do it through a separate JIRA ?

bq. addResource() should call reloadConfiguration, to eliminate duplicate code

Agreed. I didn't have common code because I was clearing the overlay in reloadConfiguration
and addResource was not. But if we remove overlay as discussed above, then it is easy to reuse.
Even if not, I can provide a private reloadConfiguration(boolean clearOverlay) and do it still.

bq. The first parameter of 'addResource' isn't needed.

You mean the 'resources' parameter, right ? I wondered why it was being used like that. Can
remove it. Again, can be part of the cleanup JIRA ?

> Implement configuration items useful for Hadoop resource manager (v1)
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-3479
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3479
>             Project: Hadoop Core
>          Issue Type: New Feature
>            Reporter: Hemanth Yamijala
>            Assignee: Hemanth Yamijala
>         Attachments: 3479.1.patch, 3479.2.patch, 3479.3.patch, 3479.patch
>
>
> HADOOP-3421 lists requirements for a new resource manager for Hadoop. Implementation
for these will require support for new configuration items in Hadoop. This JIRA is to define
such configuration, and track it's implementation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message