hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3479) Implement configuration items useful for Hadoop resource manager (v1)
Date Tue, 24 Jun 2008 16:18:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3479?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12607670#action_12607670
] 

Owen O'Malley commented on HADOOP-3479:
---------------------------------------

I like having them in the same file, with the naming scheme.

I'd propose flipping the names around so that they form a hierarchy:

{code}
<property>
    <name>hadoop.rm.queues</name>
    <value>q1,q2</value>
</property>
<property>
    <name>hadoop.rm.max-capacity</name>
    <value>200</value>
</property>
<property>
    <name>hadoop.rm.q1.max-capacity</name>
    <value>100</value>
</property>
<property>
    <name>hadoop.rm.q2.max-capacity</name>
    <value>100</value>
</property>
{code}

It would be trivial to write a pretty printer for the queue configuration that would help
spot problems with bad edits before they went live. Would that address your concerns Rob?

In terms of API, I think that Hemanth means something like:

{code}
class ResourceManager {
   private Configuration conf = ...
   public Container<String> getQueueNames()
   public static int getMaxCapactiry(String queueName);
...
}
{code}

which sounds reasonable.


> Implement configuration items useful for Hadoop resource manager (v1)
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-3479
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3479
>             Project: Hadoop Core
>          Issue Type: New Feature
>            Reporter: Hemanth Yamijala
>            Assignee: Hemanth Yamijala
>         Attachments: 3479.1.patch, 3479.patch
>
>
> HADOOP-3421 lists requirements for a new resource manager for Hadoop. Implementation
for these will require support for new configuration items in Hadoop. This JIRA is to define
such configuration, and track it's implementation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message