hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemanth Yamijala (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3479) Implement configuration items useful for Hadoop resource manager (v1)
Date Fri, 20 Jun 2008 15:09:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3479?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12606795#action_12606795
] 

Hemanth Yamijala commented on HADOOP-3479:
------------------------------------------

Doug, I fully agree with you on the need to ultimately keep all configuration management with
the Configuration class and not proliferate random formats. I opened HADOOP-3579 with the
intention of doing just that. It would be nice if you can take a look at what I propose there
and comment.

However, I feel having a wrapper around such a Configuration class that provides a closer
API for accessing Queue related configuration is a good idea. I imagine the ResourceManagerConf
class will evolve to that. It would have a Configuration class as a member variable and provide
APIs such as getQueues which will delegate calls to Configuration. I'm concerned that it would
be a while until we can arrive at a generic format that a majority of us agree with, and the
wrapper helps to abstract the rest of the code from these details.

If you look at the 2nd comment I made on this issue, I mention the format you proposed as
an option. There are disadvantages I've mentioned there (less intuitive, restrictions on queue
names, etc). However, it will have the advantage of reusing well tested code. The other option
is what I've implemented. It does repeat code, and so is undesirable. However, it is a more
intuitive format IMO. I selected this option because in my mind, I see it as a temporary arrangement
until we fix Configuration to handle hierarchies.

Honestly, if there are no major concerns from admins on the format you proposed, I would be
happy to implement it that way. Does this sound reasonable ? Any other ideas ?

> Implement configuration items useful for Hadoop resource manager (v1)
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-3479
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3479
>             Project: Hadoop Core
>          Issue Type: New Feature
>            Reporter: Hemanth Yamijala
>            Assignee: Hemanth Yamijala
>         Attachments: 3479.1.patch, 3479.patch
>
>
> HADOOP-3421 lists requirements for a new resource manager for Hadoop. Implementation
for these will require support for new configuration items in Hadoop. This JIRA is to define
such configuration, and track it's implementation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message