hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3187) Quotas for name space management
Date Wed, 04 Jun 2008 04:36:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3187?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12602161#action_12602161

Konstantin Shvachko commented on HADOOP-3187:

- FSDirectory.removeChild() should throw QuotaExceededException rather than IOException
- could you please add comments to the ignored catch IOException esp, in FSDirectory.unprotectedRenameTo().
It took me a while to realize that you just postpone processing of this till the next if statement.
The comment can say something like  // srcChild == null; goto if statement.
- FSDirectory.updateCount() is a confusing name. Can we rename it to updateSiblingCount()
or updateCountOfChildren().
- I think INodeDirectoryWithQuota should stay inside INode.java. Otherwise all other subclasses
should be factored out too.
- Public class QuotaExceededException needs JavaDoc comments.
- As long as the external API (ContentSummary) has long file counters I am fine with the implementation
that has integer counters.
This makes it an implementation restriction (changeable on demand) rather than a global file
system restriction.

The patch looks good.

> Quotas for name space management
> --------------------------------
>                 Key: HADOOP-3187
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3187
>             Project: Hadoop Core
>          Issue Type: New Feature
>            Reporter: Robert Chansler
>            Assignee: Hairong Kuang
>             Fix For: 0.18.0
>         Attachments: quota.patch, quota1.patch, quota2.patch, quota3.patch, QuotasDesign.pdf,
> Create a quota mechanism for name space management. 
> Quota set at a directory by super user restricts that number of names in and below that
> Quota tested by create() and rename().

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message