hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samuel Guo <guosi...@gmail.com>
Subject Re: Running up DataNode service in Master!
Date Tue, 27 May 2008 04:30:07 GMT
Allan Avendaño 写道:
> Regards,
>
> I'm configuring my own HDFS:
>
> etc/hosts
>
> 192.168.46.242 master.com
> 192.168.46.244 slave3.com
>
>
> ///MASTER MACHINE - master and slave...
>
> 1) masters
>
> master.com
>
> 2) slaves
>
> master.com
> slave3.com
>
> 3) hadoop-site.xml
>
>   <property>
>     <name>fs.default.name</name>
>     <value>hdfs://master.com:9527</value>
>   </property>
>   ...
>   <property>
>     <name>mapred.job.tracker</name>
>     <value>master.com:9528</value>
>   </property>
>   ...
>   <property>
>      <name>dfs.replication</name>
>      <value>2</value>
>   </property>
>
>
> ///SLAVE MACHINE ... only slave
> 1) masters
>
>  ---- EMPTY ---- (someone advice me!, it's truth?)
>
> 2) slaves
>
>  ---- EMPTY ---- (and it?)
>
> 3) hadoop-site.xml
>
>   <property>
>     <name>fs.default.name</name>
>     <value>hdfs://slave3.com:9527</value>
>   
master.com

>   </property>
>   ...
>   <property>
>     <name>mapred.job.tracker</name>
>     <value>slave3.com:9528</value>
>   
master.com

hadoop-site.xml should be same with the master machine's

>   </property>
>   ...
>   <property>
>      <name>dfs.replication</name>
>      <value>2</value>
>   </property>
>
>
> THE PROBLEM...
>
> In slave machine all services are on!
> In master machine, DATANODE service apparently doesn't run up! but, all
> service: namenode, secondarynode, jobtracker and tasktracker run up!
>
> Thanks for ur help.
>
>   


Mime
View raw message