hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3023) [HOD] build file requires exact python version
Date Wed, 14 May 2008 12:05:55 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3023?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12596740#action_12596740
] 

Vinod Kumar Vavilapalli commented on HADOOP-3023:
-------------------------------------------------

Even this Hudson run, RunHodCleanupTests took 300 secs to finish, instead of returning immediately
as expected.
{quote}
     [exec]      [exec] Running RunHodCleanupTests
     [exec]      [exec] ...
     [exec]      [exec] ----------------------------------------------------------------------
     [exec]      [exec] Ran 3 tests in 300.059s
     [exec]      [exec] 
     [exec]      [exec] OK
     [exec]      [exec] Finished RunHodCleanupTests. TestSuite Result : 0
{quote}

Created a separate JIRA to address this issue - HADOOP-3389, which blocks this issue.

> [HOD] build file requires exact python version
> ----------------------------------------------
>
>                 Key: HADOOP-3023
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3023
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: build
>            Reporter: Nigel Daley
>            Assignee: Vinod Kumar Vavilapalli
>         Attachments: HADOOP-3023
>
>
> To run the HOD pyunit tests, the build file checks that an exact python version is present:
> +      <condition property="python.versionmatched">
> +        <!--- Currently check for only 2.5.1 -->
> +        <equals arg1="${hodtest.pythonVersion}" arg2="Python 2.5.1" />
> +      </condition>
> This is too restrictive (we have 2.5.2 on our Solaris build machine).  I suggest that
you don't check the python version and instead issue a warning message if the pyunit test
fail stating that python 2.5.1 or great is required (and optionally showing them what version
they tried to use).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message