hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3023) [HOD] build file requires exact python version
Date Tue, 06 May 2008 12:36:55 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3023?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12594568#action_12594568

Vinod Kumar Vavilapalli commented on HADOOP-3023:

The failed core test org.apache.hadoop.dfs.TestBalancer.testBalancer0 is not related to this

@Nigel: The failed HOD contrib test RunHodCleanupTests runs fine on my local system(linux).
It might be that the test fails on the Hudson's solaris box, can we verify this? I thought
of resubmitting it to Hudson, but held back thinking it would unnecessarily block other patches.
If you can run all the tests again (run ant test in contrib/hod directory) or only this particular
test (run "python src/contrib/hod/testing/testHodCleanup.py"), on the Hudson machine and commit
the results here, that would help. If you want, I can run it myself, but then I need access
to this or any other solaris box.

> [HOD] build file requires exact python version
> ----------------------------------------------
>                 Key: HADOOP-3023
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3023
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: build
>            Reporter: Nigel Daley
>            Assignee: Vinod Kumar Vavilapalli
>         Attachments: HADOOP-3023
> To run the HOD pyunit tests, the build file checks that an exact python version is present:
> +      <condition property="python.versionmatched">
> +        <!--- Currently check for only 2.5.1 -->
> +        <equals arg1="${hodtest.pythonVersion}" arg2="Python 2.5.1" />
> +      </condition>
> This is too restrictive (we have 2.5.2 on our Solaris build machine).  I suggest that
you don't check the python version and instead issue a warning message if the pyunit test
fail stating that python 2.5.1 or great is required (and optionally showing them what version
they tried to use).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message