hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "dhruba borthakur (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-3146) DFSOutputStream.flush should be renamed as DFSOutputStream.fsync
Date Thu, 03 Apr 2008 22:09:24 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-3146?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

dhruba borthakur updated HADOOP-3146:
-------------------------------------

    Attachment: flushToFsync2.patch

The previous patch did not change one unit test that was still invoking the old flush() API.


> DFSOutputStream.flush should be renamed as DFSOutputStream.fsync
> ----------------------------------------------------------------
>
>                 Key: HADOOP-3146
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3146
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs
>            Reporter: Runping Qi
>            Assignee: dhruba borthakur
>            Priority: Blocker
>             Fix For: 0.17.0
>
>         Attachments: flushToFsync.patch, flushToFsync2.patch
>
>
> Starting fron hadoop-0.17, calling flush of dfs becomes very expensive.
> The current implementation of flush should be renamed as sync.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message