hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3146) DFSOutputStream.flush should be renamed as DFSOutputStream.fsync
Date Fri, 04 Apr 2008 09:13:24 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3146?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12585454#action_12585454
] 

Hadoop QA commented on HADOOP-3146:
-----------------------------------

+1 overall.  Here are the results of testing the latest attachment 
http://issues.apache.org/jira/secure/attachment/12379324/flushToFsync2.patch
against trunk revision 643282.

    @author +1.  The patch does not contain any @author tags.

    tests included +1.  The patch appears to include 9 new or modified tests.

    javadoc +1.  The javadoc tool did not generate any warning messages.

    javac +1.  The applied patch does not generate any new javac compiler warnings.

    release audit +1.  The applied patch does not generate any new release audit warnings.

    findbugs +1.  The patch does not introduce any new Findbugs warnings.

    core tests +1.  The patch passed core unit tests.

    contrib tests +1.  The patch passed contrib unit tests.

Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2155/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2155/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2155/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2155/console

This message is automatically generated.

> DFSOutputStream.flush should be renamed as DFSOutputStream.fsync
> ----------------------------------------------------------------
>
>                 Key: HADOOP-3146
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3146
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs
>            Reporter: Runping Qi
>            Assignee: dhruba borthakur
>            Priority: Blocker
>             Fix For: 0.17.0
>
>         Attachments: flushToFsync.patch, flushToFsync2.patch
>
>
> Starting fron hadoop-0.17, calling flush of dfs becomes very expensive.
> The current implementation of flush should be renamed as sync.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message