hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-544) Replace the job, tip and task ids with objects.
Date Tue, 29 Apr 2008 13:39:56 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-544?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Enis Soztutar updated HADOOP-544:

    Attachment: id_v6.patch

A 5% improvement, wow ! 

Thanks to the help from Arun, I've updated the patch. This version is a first attempt to build
the naming convention. 
Now we have JobID, TaskID, TaskAttemptID classes. The prefixes for these are also changed
to "job_", "task_" and "attempt", respectively. Surely any code which parsed these names from
the strings will break, but thats exactly why we hereby introduce xxxID classes. 

As a side note, we keep tipId and taskId variable names, in some places. It will be good if
they are also refactored, but I prefer to delay this in a later issue. 

Thanks for the benchmark, and the reviews. 

> Replace the job, tip and task ids with objects.
> -----------------------------------------------
>                 Key: HADOOP-544
>                 URL: https://issues.apache.org/jira/browse/HADOOP-544
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.18.0
>            Reporter: Owen O'Malley
>            Assignee: Enis Soztutar
>             Fix For: 0.18.0
>         Attachments: api-changes.tgz, id_v1.patch, id_v2.patch, id_v3.patch, id_v4.patch,
id_v5.patch, id_v6.patch, id_wip1.patch
> I think that it is silly to have tools parsing the strings that the framework builds
for task ids. I propose:
> class JobId implements Writable {
>    public int getJobId() {...}
> }
> class TaskId implements Writable {
>   public JobId getJobId(); 
>   public boolean isMap() { ... }
>   public int getTaskId() { ... }
> }
> class TaskAttemptId implements Writable {
>   public TaskId getTaskId();
>   public int getAttemptId();
> }
> each of the classes will have a toString() method that generates the current string.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message