hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemanth Yamijala (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (HADOOP-2897) [HOD] Remove script option from the core hod framework
Date Mon, 03 Mar 2008 05:54:50 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-2897?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Hemanth Yamijala resolved HADOOP-2897.

    Resolution: Won't Fix

In a discussion internally, it was decided to go with the approach of using the core hod interface
itself for implementing this option, as opposed to a new command. This is in the interest
of usability, and the fact that the script option is something existing users of HOD are quite
used to. So, I am resolving this issue as 'Won't fix'

> [HOD] Remove script option from the core hod framework
> ------------------------------------------------------
>                 Key: HADOOP-2897
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2897
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: contrib/hod
>    Affects Versions: 0.16.0
>            Reporter: Hemanth Yamijala
>            Assignee: Hemanth Yamijala
>             Fix For: 0.16.1
> Hod currently allows the user to specify and run a hadoop script after allocation, and
deallocating as soon as the script is done. For e.g.
> hod -m 3 -z ~/hadoop.script
> allocates 3 nodes, and runs ~/hadoop.script, then deallocates
> This is a convenient way single line wrapper around 4-5 commands that users have to write
themselves. We have this because:
> - hod 0.3 does not provide an easy way to combine these into a single operation, because
of the HOD shell.
> - even in hod 0.4, users have to carefully write some error checking code to make sure
their cluster is allocated successfully, before running the script and their HADOOP_CONF_DIR
should be set correctly.
> - users can free up clusters as soon as they are done.
> The requirements make sense. But having this as part of the core hod interface seems
incorrect. The interface should be an orthogonal set of commands that each just do one thing
well. The script option should be converted to a simple wrapper that can be part of the hod
project. This way, users can enjoy the benefits of not having to write such a script themselves,
while the hod codebase can still be clean.
> One disadvantage if we change this is that users will need to remember one more command.
But given hod 0.4 is a new interface anyway, it is better to address now, rather than later.
And we can alleviate this a bit by making sure options are consistently named between hod
and the wrapper script.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message