hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemanth Yamijala (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2861) [HOD] Improve the user interface for the HOD commands
Date Mon, 03 Mar 2008 17:44:50 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12574622#action_12574622

Hemanth Yamijala commented on HADOOP-2861:

Code looks very good. Very cosmetic comments - mostly on messages:

- allocate and script operations' help must use the term 'nodecount' rather than 'nodes'.
As in -n <nodecount> instead of <nodes> as the latter is confusing
- help for script says "runs the specified script on the cluster". This is misleading. We
could say, "runs the specified script using the allocated cluster"
- help for allocate when arguments are not given mentions "min-max nodes". There is no support
for this. Remove.
- hod deallocate -n <dir>. As the argument for cluster directory is not given, I was
expecting it to print usage, as it does in other scenarios. Here it printed invalid nodecount
- When hod <sub-command> and -s is given, we say "Script execution and hod operations
are mutually exclusive." Instead we can say "Script operation is mutually exclusive with other
HOD operations"

The documentation part of the patch is broken. I got errors when generating the documentation.
Can you please check that and reattach a patch for me to review the documentation changes

> [HOD] Improve the user interface for the HOD commands
> -----------------------------------------------------
>                 Key: HADOOP-2861
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2861
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: contrib/hod
>    Affects Versions: 0.16.0
>            Reporter: Hemanth Yamijala
>            Assignee: Vinod Kumar Vavilapalli
>             Fix For: 0.16.1
>         Attachments: hadoop-2861
> The current command line for HOD is not user-friendly or conventional. Following improvements
are required:
> - We shouldn't require the quotes around the operation.
> - Can we define a HOD_CLUSTER_DIR environment variable which would be used by default
> With these two, one can imagine a very simple command line for HOD. Something like:
> hod-allocate 3
> hod-deallocate
> hod-allocate 3 ~/hod-clusters/test
> hod-deallocate ~/hod-clusters/test
> This would also be backward compatible for people who're used to the current model.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message