hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2911) [HOD] Make the information printed by allocate and info commands less verbose and clearer
Date Wed, 05 Mar 2008 14:01:41 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12575348#action_12575348

Hadoop QA commented on HADOOP-2911:

-1 overall.  Here are the results of testing the latest attachment 
against trunk revision 619744.

    @author +1.  The patch does not contain any @author tags.

    tests included -1.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no tests are needed for this patch.

    javadoc +1.  The javadoc tool did not generate any warning messages.

    javac +1.  The applied patch does not generate any new javac compiler warnings.

    release audit +1.  The applied patch does not generate any new release audit warnings.

    findbugs +1.  The patch does not introduce any new Findbugs warnings.

    core tests -1.  The patch failed core unit tests.

    contrib tests +1.  The patch passed contrib unit tests.

Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/1894/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/1894/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/1894/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/1894/console

This message is automatically generated.

> [HOD] Make the information printed by allocate and info commands less verbose and clearer
> -----------------------------------------------------------------------------------------
>                 Key: HADOOP-2911
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2911
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: contrib/hod
>    Affects Versions: 0.16.0
>            Reporter: Hemanth Yamijala
>            Assignee: Vinod Kumar Vavilapalli
>             Fix For: 0.16.1
>         Attachments: hadoop-2911, hadoop-2911.1
> Currently hod prints the following information as part of the allocate command at an
'INFO' verbose level:
> Service Registry started
> Torque job id
> Ringmaster ..
> HDFS UI at ..
> Mapred UI at ..
> The "service registry started" line is misleading and isn't very useful. This should
be removed.
> Torque job id is misleading in terminology because job id also clashes with Mapred "job
id". The proposal is to make it something like 'cluster id' or something similar.
> Ringmaster information is useful for debugging, but not for regular users.
> Similar changes should be made to the hod info command as well. The naming should be
clear and consistent. There, we print all of the above information and in addition, also print
the number of nodes as min,max. Because we don't really support the min,max number of nodes,
we can remove that and probably print only the number of nodes allocated.
> All information must continue to be printed at a higher verbosity level.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message